DragonFly On-Line Manual Pages
LOCK(9) DragonFly Kernel Developer's Manual LOCK(9)
lockinit, lockcount, lockmgr, lockstatus, lockmgr_printinfo, lockowned --
lockmgr family of functions
lockinit(struct lock *lkp, const char *wmesg, int timo, int flags);
lockuninit(struct lock *lkp);
lockcount(struct lock *lkp);
lockcountnb(struct lock *lkp);
lockmgr(struct lock *lkp, u_int flags);
lockstatus(struct lock *lkp, struct thread *td);
lockmgr_printinfo(struct lock *lkp);
lockowned(struct lock *lkp);
The lockinit() function is used to initialize a lock. It must be called
before any operation can be performed on a lock. Its arguments are:
lkp A pointer to the lock to initialize.
wmesg The lock message. This is used for both debugging output and
timo The timeout value passed to tsleep(9).
flags The flags the lock is to be initialized with.
LK_NOWAIT Do not sleep while acquiring the lock.
LK_SLEEPFAIL Fail after a sleep.
LK_CANRECURSE Allow recursive exclusive locks.
LK_TIMELOCK Use timo during a sleep; otherwise, 0 is used.
The lockuninit() function destroys a lock that was previously initialized
The lockcount() function returns a count of the number of exclusive locks
and shared locks held against the lock lkp.
The lockcountnb() function is a non-blocking counter-part of lockcount().
which, can be safely used in assertion statements e.g. a KASSERT(9).
The lockmgr() function handles general locking functionality within the
kernel, including support for shared and exclusive locks, and recursion.
lockmgr() is also able to upgrade and downgrade locks.
Its arguments are:
lkp A pointer to the lock to manipulate.
flags Flags indicating what action is to be taken.
LK_SHARED Acquire a shared lock. If an exclusive lock is
currently held, it will be downgraded.
LK_EXCLUSIVE Acquire an exclusive lock. If an exclusive lock
is already held, and LK_CANRECURSE is not set, the
system will panic(9).
LK_DOWNGRADE Downgrade exclusive lock to a shared lock. Down-
grading a shared lock is not permitted. If an
exclusive lock has been recursed, all references
will be downgraded.
LK_EXCLUPGRADE Upgrade a shared lock to an exclusive lock. Fails
with EBUSY if there is someone ahead of you in
line waiting for an upgrade. If this call fails,
the shared lock is lost. Attempts to upgrade an
exclusive lock will cause a panic(9).
LK_UPGRADE Upgrade a shared lock to an exclusive lock. If
this call fails, the shared lock is lost.
Attempts to upgrade an exclusive lock will cause a
LK_RELEASE Release the lock. Releasing a lock that is not
held can cause a panic(9).
LK_SLEEPFAIL Fail if operation has slept.
LK_NOWAIT Do not allow the call to sleep. This can be used
to test the lock.
LK_CANRECURSE Allow recursion on an exclusive lock. For every
lock there must be a release.
The lockstatus() function returns the status of the lock in relation to
the thread passed to it. Note that if td is NULL and an exclusive lock
is held, LK_EXCLUSIVE will be returned.
The lockmgr_printinfo() function prints debugging information about the
lock. It is used primarily by VOP_PRINT(9) functions.
The lockowned() function is used to determine whether the calling thread
owns a lock.
The lockcount() function returns an integer greater than or equal to
The lockmgr() function returns 0 on success and non-zero on failure.
The lockstatus() function returns:
LK_EXCLUSIVE An exclusive lock is held by the thread td.
LK_EXCLOTHER An exclusive lock is held by someone other than the thread
LK_SHARED A shared lock is held.
0 The lock is not held by anyone.
The lockowned() function returns a non-zero return value if the caller
owns the lock shared or exclusive.
The lock manager itself is implemented within the file
/sys/kern/kern_lock.c. Data structures and function prototypes for the
lock manager are in /sys/sys/lock.h.
lockmgr() fails if:
[EBUSY] LK_NOWAIT was set, and a sleep would have been
[ENOLCK] LK_SLEEPFAIL was set and lockmgr() did sleep.
[EINTR] PCATCH was set in the lock priority, and a signal was
delivered during a sleep. Note the ERESTART error
[ERESTART] PCATCH was set in the lock priority, a signal was
delivered during a sleep, and the system call is to be
[EWOULDBLOCK] a non-zero timeout was given, and the timeout expired.
Upgrade attempts that fail result in the loss of the lock that is cur-
rently held. Also, it is invalid to upgrade an exclusive lock, and a
panic(9) will be the result of trying.
locking(9), panic(9), tsleep(9), VOP_PRINT(9)
The lock manager appeared in DragonFly 1.0.
The lock manager API first appeared in 4.4BSD-Lite2.
This man page was written by Chad David <firstname.lastname@example.org>.
DragonFly 4.1 January 19, 2014 DragonFly 4.1