DragonFly On-Line Manual Pages
LIBMAP.CONF(5) DragonFly File Formats Manual LIBMAP.CONF(5)
libmap.conf -- configuration file for dynamic object dependency mapping
The libmap functionality of ld-elf.so.1(1) allows dynamic object depen-
dencies to be mapped to arbitrary names.
The configuration file consists of two whitespace separated columns; the
left hand side containing the mapping candidate and the right hand side
containing the mapping. Dependencies are matched against candidates and
replaced with the mappings.
Two special directives are available:
Parse the contents of file before continuing with the current
Parse the contents of every file in dir that ends in .conf before
continuing with the current file.
Any file or directory encountered while processing include or includedir
directives will be parsed exactly once, even if it is encountered multi-
Constrained mappings may be specified by enclosing the name of the exe-
cutable or library in brackets. All mappings following a constraint will
only be evaluated for that constraint. Constraints can be one of three
Exact The constraint is matched literally so that only an executable
with an identical fully qualified pathname will match the con-
straint. This means that the executable /usr/bin/foo will not
match a constraint for /usr/bin/./foo and vice-versa. This is
the default constraint type.
A constraint with no path is matched against the basename of the
executable. foo will match /bin/foo, /usr/local/sbin/foo, or any
other executable named foo, no matter what its path is.
A constraint with a trailing slash is prefix-matched against the
full pathname of the executable. /usr/bin/ will match any exe-
cutable with a path starting with /usr/bin.
Note that the executable path matched against is the path parameter in an
exec*() function call. The Directory or Exact constraints can only match
when the executable is called with a full pathname. Most programs exe-
cuted from a shell are run without a full path, via exec*p(), so the
Basename constraint type is the most useful.
WARNING! Constrained mappings must never appear first in the configura-
tion file. While there is a way to specify the ``default'' constraint,
its use is not recommended.
The most common use at the date of writing is for allowing multiple POSIX
threading libraries to be used on a system without relinking or changing
This mechanism has also been used to create shims to allow Linux shared
libraries to be dynamically loaded into FreeBSD binaries. In this case,
an Exact constraint is used for the Linux shared library, mapping
libraries it depends on to a wrapper. The wrapper then defines any
needed symbols for the Linux shared library and relies on its libraries
not being mapped to provide actual implementations. It appears that only
libraries loaded via dlopen(3) will work correctly. The symbol version
information in shared libraries is checked at link time, but at run time
the version information is currently ignored.
/etc/libmap.conf The libmap configuration file.
# candidate mapping
libc_r.so.6 libpthread.so.2 # Everything that uses 'libc_r'
libc_r.so libpthread.so # now uses 'libpthread'
[/tmp/mplayer] # Test version of mplayer uses libc_r
[/usr/local/jdk1.4.1/] # All Java 1.4.1 programs use libthr
# This works because "javavms" executes
# programs with the full pathname
# Glue for Linux-only EPSON printer .so to be loaded into cups, etc.
The libmap.conf manual page and libmap functionality first appeared in
This manual page was written by Matthew N. Dodd <email@example.com>.
DragonFly 3.5 May 3, 2012 DragonFly 3.5