DragonFly On-Line Manual Pages
JME(4) DragonFly Kernel Interfaces Manual JME(4)
NAME
jme -- JMicron Gigabit/Fast Ethernet driver
SYNOPSIS
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
device miibus
device jme
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
if_jme_load="YES"
DESCRIPTION
The jme device driver provides support for JMicron JMC250 PCI Express
Gigabit Ethernet controllers and JMicron JMC260 PCI Express Fast Ethernet
controllers.
All LOMs supported by the jme driver have TCP/UDP/IP checksum offload for
both transmit and receive, TCP segmentation offload (TSO), receive side
scaling (RSS), multiple vector MSI-X, hardware VLAN tag
stripping/insertion features, an interrupt coalescing/moderation
mechanism as well as a 64-bit multicast hash filter. Up to 4 reception
queues can be enabled. By default, the jme driver will try enabling as
many reception queues as allowed by the number of CPUs in the system.
The JMC250 also supports Jumbo Frames (up to 9216 bytes), which can be
configured via the interface MTU setting. Selecting an MTU larger than
1500 bytes with the ifconfig(8) utility configures the adapter to receive
and transmit Jumbo Frames.
The jme driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
1000baseT Set 1000baseT operation over twisted pair.
The jme driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8). The
jme driver supports polling(4).
Loader Tunables
By default, the driver will use MSI-X if it is supported. This behavior
can be turned off by setting the following tunable: (X is the device unit
number):
hw.jme.msix.enable=0
hw.jmeX.msix.enable=0
If MSI-X is disabled, the driver will use MSI if it is supported. This
behavior can be turned off by setting the following tunable:
hw.jme.msi.enable=0
hw.jmeX.msi.enable=0
If MSI is used, MSI's target CPU can be changed by the following tunable:
hw.jmeX.msi.cpu
The maximum allowed value for this tunable is the number of CPUs minus
one.
Number of reception queues that can be enabled:
hw.jme.rx_ring_count
hw.jmeX.rx_ring_count
Maximum allowed value for these tunables is 4. Setting these tunables to
0 allows driver to enable as many reception queues as allowed by the
number of CPUs.
Number of reception descriptors that can be used:
hw.jme.rx_desc_count
hw.jmeX.rx_desc_count
Maximum allowed value for these tunables is 1024.
Number of transmission descriptors that can be used:
hw.jme.tx_desc_count
hw.jmeX.tx_desc_count
Maximum allowed value for these tunables is 1024.
MIB Variables
A number of per-interface variables are implemented in the dev.jme.X
branch of the sysctl(3) MIB.
tx_coal_to Maximum amount of time to delay for TX completion
interrupt in units of 1us. The accepted range is 1 to
65535, the default is 250 (250us).
tx_coal_pkt Maximum number of packets to fire TX completion interrupt.
The accepted range is 0 to 255, the default is 128.
Packet count based TX interrupt coalescing could be
disabled by setting this variable to 0.
rx_coal_to Maximum amount of time to delay for RX completion
interrupt in units of 1us. The accepted range is 1 to
65535, the default is 150 (150us).
rx_coal_pkt Maximum number of packets to fire RX completion interrupt.
The accepted range is 0 to 255, the default is 64. Packet
count based RX interrupt coalescing could be disabled by
setting this variable to 0.
rx_desc_count Number of RX descriptors per-ring (read-only). Use the
tunable hw.jme.rx_desc_count to configure it.
tx_desc_count Number of TX descriptors (read-only). Use the tunable
hw.jme.tx_desc_count to configure it.
rx_ring_count Number of RX rings (read-only). Use the tunable
hw.jme.rx_ring_count to configure it.
tx_wreg The number of transmission descriptors should be setup
before the hardware register is written. Setting this
value too high will have negative effect on transmission
timeliness. Setting this value too low will hurt overall
transmission due to the frequent hardware register
writing.
SEE ALSO
altq(4), arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4),
polling(4), vlan(4), ifconfig(8)
HISTORY
The jme driver was written by Pyun YongHyeon <yongari@FreeBSD.org>. It
first appeared in FreeBSD 7.1 and was imported into DragonFly 2.1.
Sepherosa Ziehau added the receive side scaling and multiple vector MSI-X
support to DragonFly.
DragonFly 4.7 May 29, 2017 DragonFly 4.7