DragonFly On-Line Manual Pages
IPMI(4) DragonFly Kernel Interfaces Manual IPMI(4)
NAME
ipmi -- OpenIPMI compatible IPMI interface driver
SYNOPSIS
device ipmi
DESCRIPTION
The IPMI (Intelligent Platform Management Interface) is a standard for
monitoring system hardware by permitting generic code to detect and
monitor the sensors in a system. The IPMI standard offers watchdog
support, an FRU database, and other support extensions. It is currently
being adopted by the makers of many single board and embedded system
manufacturers.
The ipmi driver in DragonFly is heavily adopted from the standard and
Linux driver; however, not all features described in the standard are
supported.
SYSCTL VARIABLES
The following sysctl(8) variables are available:
dev.ipmi.%d.watchdog_enable Enable watchdog functionality.
dev.ipmi.%d.watchdog_timeout Set the watchdog timeout.
IOCTLS
Sending and receiving messages through the ipmi driver requires the use
of ioctl(2). The ioctls are used due to the complexity of data sent to
and from the device. The ioctl(2) command codes below are defined in
<sys/ipmi.h>. The third argument to ioctl(2) should be a pointer to the
type indicated.
Currently the following ioctls are supported:
IPMICTL_RECEIVE_MSG (struct ipmi_recv)
Receive a message. Possible error values:
[EAGAIN] No messages are in the process queue.
[EFAULT] An address supplied was invalid.
[EMSGSIZE] The address could not fit in the message
buffer and will remain in the buffer.
IPMICTL_RECEIVE_MSG_TRUNC (struct ipmi_recv)
Like IPMICTL_RECEIVE_MSG but if the message cannot fit into the
buffer, it will truncate the contents instead of leaving the data
in the buffer.
IPMICTL_SEND_COMMAND (struct ipmi_req)
Send a message to the interface. Possible error values:
[EFAULT] An address supplied was invalid.
[ENOMEM] Buffers could not be allowed for the command,
out of memory.
IPMICTL_SET_MY_ADDRESS_CMD (unsigned int)
Set the slave address for source messages.
IPMICTL_GET_MY_ADDRESS_CMD (unsigned int)
Get the slave address for source messages.
IPMICTL_SET_MY_LUN_CMD (unsigned int)
Set the slave LUN for source messages.
IPMICTL_GET_MY_LUN_CMD (unsigned int)
Get the slave LUN for source messages.
Unimplemented Ioctls
IPMICTL_REGISTER_FOR_CMD (struct ipmi_cmdspec)
Register to receive a specific command. Possible error values:
[EFAULT] An supplied address was invalid.
[EBUSY] The network function/command is already in
use.
[ENOMEM] Could not allocate memory.
IPMICTL_UNREGISTER_FOR_CMD (struct ipmi_cmdspec)
Unregister to receive a specific command. Possible error values:
[EFAULT] An address supplied was invalid.
[ENOENT] The network function/command was not found.
Stub Only Ioctl
IPMICTL_SET_GETS_EVENTS_CMD (int)
Set whether this interface receives events. Possible error
values:
[EFAULT] An address supplied was invalid.
SEE ALSO
ioctl(2), watchdog(4), watchdogd(8), wdog(9)
HISTORY
The ipmi driver first appeared in FreeBSD 6.2. It was imported to
DragonFly 4.1.
AUTHORS
The ipmi driver was written by Doug Ambrisko <ambrisko@FreeBSD.org>.
This manual page was written by Tom Rhodes <trhodes@FreeBSD.org>.
BUGS
Not all features of the MontaVista driver are supported.
Currently, IPMB and BT modes are not implemented.
DragonFly 4.1 December 14, 2014 DragonFly 4.1