DragonFly On-Line Manual Pages
HPTRR(4) DragonFly Kernel Interfaces Manual HPTRR(4)
hptrr -- HighPoint RocketRAID device driver
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The hptrr driver provides support for HighPoint's RocketRAID based RAID
These devices support SATA/ATA disk drives and provide RAID0 (striping),
RAID1 (mirroring), and RAID5 functionality.
The following tunables are settable from the loader:
Set to 1 to permit the driver to attach to chips with generic
Marvell (non-HighPoint) PCI identification. These chips are also
supported by nata(4). Some vendors are using these chips without
providing a RAID BIOS.
The hptrr driver supports the following RAID controllers:
* RocketRAID 172x series
* RocketRAID 174x series
* RocketRAID 2210
* RocketRAID 222x series
* RocketRAID 2240
* RocketRAID 230x series
* RocketRAID 231x series
* RocketRAID 232x series
* RocketRAID 2340
* RocketRAID 2522
The hptrr driver only works on the i386 and x86_64 platforms as it
requires a blob from the manufacturer which they only supply for these
This driver does not support the RR182x series controller. See the
hptmv(4) manual page for details on support.
cam(4), hpt27xx(4), hptiop(4), hptmv(4), nata(4), loader(8)
The hptrr device driver first appeared in FreeBSD 6.3.
The hptrr device driver was written by HighPoint Technologies, Inc., and
ported to FreeBSD by Scott Long. This manual page was written by David
The hptrr driver does not support manipulating the RAID from the OS,
RAIDs need to be set up from the on-board BIOS.
DragonFly 4.1 August 3, 2012 DragonFly 4.1