DragonFly On-Line Manual Pages
HPTMV(4) DragonFly Kernel Interfaces Manual HPTMV(4)
hptmv -- HighPoint RocketRAID 182x device driver
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The hptmv driver provides support for HighPoint's RocketRAID 182x based
These devices support ATA disk drives and provide RAID0 (striping), RAID1
(mirroring), and RAID5 functionality.
The hptmv driver supports the following ATA RAID controllers:
* HighPoint's RocketRAID 182x series
The hptmv driver only works on the i386 and x86_64 platforms as it
requires a blob from the manufacturer which they only supply for these
hpt27xx(4), hptiop(4), hptrr(4), kld(4), kldload(8), loader(8)
The hptmv device driver first appeared in FreeBSD 5.3.
The hptmv device driver was written by HighPoint Technologies, Inc., and
ported to FreeBSD by Scott Long. This manual page was written by David
The hptmv driver does not support manipulating the RAID from the OS,
RAIDs need to be set up from the on-board BIOS.
DragonFly 3.7 January 4, 2011 DragonFly 3.7