DragonFly On-Line Manual Pages
EHCI(4) DragonFly Kernel Interfaces Manual EHCI(4)
ehci -- USB Enhanced Host Controller driver
The ehci driver provides support for the USB Enhanced Host Controller
Interface, which is used by USB 2.0 controllers.
EHCI controllers are peculiar in that they can only handle the USB 2.0
protocol. This means that they normally have one or more companion con-
trollers (i.e., ohci(4) or uhci(4)) handling USB 1.x devices. Conse-
quently each USB connector is electrically connected to two USB con-
trollers. The handling of this is totally automatic, but can be noticed
since USB 1.x and USB 2.0 devices plugged in to the same connector appear
to connect to different USB busses.
ohci(4), uhci(4), usb(4), xhci(4)
The ehci device driver first appeared in FreeBSD 5.1.
When the kernel has been compiled with options USB_DEBUG, some tunables
become available that affect the behavior of ehci. These tunables can be
set at the loader(8) prompt before booting the kernel or stored in
This tunable enables the lost interrupt quirk. The default value
is 0 (off).
This tunable enables the EHCI doorbell quirk. The default value
is 0 (off).
This tunable disables USB devices to attach like HIGH-speed ones
and will force all attached devices to attach to the FULL- or
LOW-speed companion controller. The default value is 0 (off).
DragonFly 4.1 March 13, 2014 DragonFly 4.1