DragonFly On-Line Manual Pages
EHCI(4) DragonFly Kernel Interfaces Manual EHCI(4)
ehci -- USB Enhanced Host Controller driver
The ehci driver provides support for the USB Enhanced Host Controller
Interface, which is used by USB 2.0 controllers.
EHCI controllers are peculiar in that they can only handle the USB 2.0
protocol. This means that they normally have one or more companion con-
trollers (i.e., ohci(4) or uhci(4)) handling USB 1.x devices. Conse-
quently each USB connector is electrically connected to two USB con-
trollers. The handling of this is totally automatic, but can be noticed
since USB 1.x and USB 2.0 devices plugged into the same connector appear
to connect to different USB busses.
The ehci driver is automatically loaded upon boot. To disable this
behavior temporarily, the ehci_load variable can be unset at the loader
prompt (see loader(8)). To disable it permanently, the
hint.ehci.0.disabled tunable can be set to 1 in /boot/loader.conf.
cardbus(4), ohci(4), pci(4), uhci(4), usb(4)
The ehci driver appeared in DragonFly 1.0.
There is no support (yet) for interrupt or isochronous transfers.
DragonFly 3.5 July 4, 2010 DragonFly 3.5