DragonFly On-Line Manual Pages
ECC(4) DragonFly Kernel Interfaces Manual ECC(4)
ecc -- ECC memory controller support
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The ecc device attaches to an ECC memory controller. If ECC support is
enabled in the BIOS, the device will poll the controller once a second
and report any corrections or uncorrectable errors.
The ecc driver supports the following memory controllers:
* AMD 8000 memory controller
* AMD 8151 memory controller
* Intel E3 memory controller
* Intel E3 v2 memory controller
* Intel E3 v3 memory controller
* Intel E5 v2 memory controller
* Intel E5 v3 memory controller
The ecc device driver first appeared in DragonFly 1.7.
The ecc driver was written by Matthew Dillon.
DragonFly 4.1 February 5, 2015 DragonFly 4.1