DragonFly On-Line Manual Pages
DRM(4) DragonFly Kernel Interfaces Manual DRM(4)
drm -- Direct Rendering Manager (DRI kernel support)
The Direct Rendering Manager is part of the Direct Rendering
Infrastructure (see http://dri.freedesktop.org/) for supporting video
acceleration. For older chipsets it's used for 3d acceleration only, but
newer chipsets may require drm for 2d acceleration (XVideo, EXA) as well.
The drm drivers provide support for the following chipsets:
Module Kernel option Chipset
i915kms.ko n/a Intel i915, i945, i965, G3x, G4x
mach64.ko mach64drm Mach64 (3D Rage Pro, Rage)
mga.ko mgadrm Matrox G00, G50
r128.ko r128drm Rage 128
radeon.ko radeondrm Radeon
savage.ko savagedrm S3 Savage
sis.ko sisdrm SiS
tdfx.ko tdfxdrm 3dfx (Voodoo)
In most cases Xorg(1) will take care of loading the appropriate modules
and it is not necessary to modify loader.conf(5) or the kernel configura-
tion to enable drm support.
Newer versions of Xorg(1), like the one from dports(7), do a pretty good
job of figuring out the right configuration on their own, so having no
xorg.conf(5) file at all is usually the best advice. If for some reason
an xorg.conf(5) is preferred, DRI must be enabled:
With KMS, DRI is always enabled since the drm is always required.
If Xorg(1) acceleration fails to initialize with a ``contigmalloc_map:
failed size...'' error in dmesg, the reserve of memory for DMA ran out
early and should be increased to a sufficiently high value by setting the
vm.dma_reserved loader tunable. A read only sysctl(8) variable of the
same name is provided for obtaining its current value.
Debugging output can be enabled and disabled by setting the sysctl(8)
DRM was first available for Linux. Subsequently Eric Anholt ported the
DRM kernel modules to FreeBSD.
Disable AIGLX if necessary (xorg.conf):
Option "AIGLX" "off"
options DRM_DEBUG can slow DRI down a lot, disable it once drm works.
DragonFly 3.7 September 13, 2013 DragonFly 3.7