DragonFly On-Line Manual Pages
DMESG(8) DragonFly System Manager's Manual DMESG(8)
dmesg -- display the system message buffer
dmesg [-a] [-c] [-f[f]] [-M core] [-N system] [-n dumpnr]
The dmesg utility displays the contents of the system message buffer. If
neither the -N nor the -M option is specified, the buffer is read from
the currently running kernel via the sysctl(3) interface. Otherwise, the
buffer is read from the specified core file (or from the default one),
using the name list from the specified kernel image (or from the default
The options are as follows:
-a Show all data in the message buffer. This includes any syslog
records and /dev/console output.
-c Clear the kernel buffer after printing.
-f[f] After the initial message buffer dump dmesg monitors the kernel
for additional data and displays it as it arrives. dmesg will
not terminate until killed in this mode. If this option is spec-
ified twice, dmesg will live loop (use the cpu heavily) to obtain
updates as quickly as possible. This second mode should only be
used when trying to debug a kernel crashing situation.
-M Extract values associated with the name list from the specified
core instead of the default /dev/kmem.
-N Extract the name list from the specified system instead of the
default, which is the kernel image the system has booted from.
Use the kernel core dump file numbered dumpnr for debugging.
/var/run/dmesg.boot usually a snapshot of the buffer contents taken soon
after file systems are mounted at startup time
The dmesg utility appeared in 4.0BSD.
DragonFly 4.3 May 10, 2013 DragonFly 4.3