DragonFly On-Line Manual Pages
DHCP(8) DragonFly System Manager's Manual DHCP(8)
dhcp -- configuring DragonFly for DHCP
The Dynamic Host Configuration Protocol (DHCP) allows hosts on a TCP/IP
network to configure one or more network interfaces based on information
collected from a DHCP server in response to a DHCP request. This mecha-
nism is often used, for example, by cable modem and DSL network providers
to simplify network configurations for their clients/customers.
Information typically contained within a DHCP response includes an IP
address for the interface, subnet mask, broadcast address, router (gate-
way) listing, domain name server listing, and the interface's MTU.
To set up DragonFly as a DHCP client:
1. For each interface that is to be configured via DHCP, add
``DHCP'' to the ifconfig_<interface> variable in /etc/rc.conf.
See rc.conf(5) for more information on the format of this
The /etc/network.subr script reads each of these variables at
boot-time and runs the dhclient(8) program for each interface
that is to be configured via DHCP.
2. [Optional] To tweak settings, edit /etc/dhclient.conf. This
file is shipped with the system. See dhclient.conf(5) and
dhclient(8) for details.
To set up DragonFly as a DHCP server:
1. Install dhcpd(8) (available in pkgsrc(7)).
2. Edit /usr/pkg/etc/dhcp/dhcpd.conf. See dhcpd.conf(5) and
dhcpd(8) for details.
3. Edit /etc/rc.conf and set dhcpd_flags="". This will cause
DragonFly to start the dhcpd(8) daemon at boot-time and listen
for DHCP requests on the local network. To start it manually,
execute the following command:
# /usr/pkg/sbin/dhcpd [netif1 netif2 ...]
The DHCP client and server use the Berkeley Packet Filter (BPF). Ensure
the kernel has been compiled with BPF support and at least one /dev/bpf*
file exists per broadcast network interface that is attached to the sys-
tem. This is almost always the case and should only be considered if all
other troubleshooting options have failed.
See dhcpd(8) for information on other available options. Note, however,
that most of the flags are useful only for debugging purposes.
DHCP server configuration file
/etc/rc.conf configuration file where DHCP client configura-
tion is set for individual interfaces and
dhcpd_flags must be set
/etc/dhclient.conf DHCP client configuration file
dhclient.conf(5), dhcpd.conf(5) (pkgsrc/net/isc-dhcpd4), dhclient(8),
dhcpd(8) (pkgsrc/net/isc-dhcpd4), dhcrelay(8) (pkgsrc/net/isc-dhcrelay4)
DragonFly 3.5 October 15, 2008 DragonFly 3.5