DragonFly On-Line Manual Pages

Search: Section:  


DEVICE_FIND_CHILD(9)  DragonFly Kernel Developer's Manual DEVICE_FIND_CHILD(9)

NAME

device_find_child -- search for a child of a device

SYNOPSIS

#include <sys/param.h> #include <sys/bus.h> device_t device_find_child(device_t dev, const char* name, int unit);

DESCRIPTION

This function looks for a specific child of dev. with the given name and unit.

RETURN VALUES

If it exists, the child device is returned, otherwise NULL.

SEE ALSO

device_add_child(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 3.5 June 16, 1998 DragonFly 3.5

Search: Section: