DragonFly On-Line Manual Pages
CRYPTO(4) DragonFly Kernel Interfaces Manual CRYPTO(4)
NAME
crypto, cryptodev - hardware crypto access driver
SYNOPSIS
device crypto
device cryptodev
DESCRIPTION
The crypto driver provides a device-independent framework to support
cryptographic operations in the kernel. The cryptodev driver provides
userland applications access to this support through the /dev/crypto
device. This node primarily operates in an ioctl(2) based model,
permitting a variety of applications to query device capabilities, submit
transactions, and get results.
If count given in the specification, and is greater than 0, a maximum of
one crypto device is created.
The following ioctl(2) calls apply only to the crypto devices:
CIOCGSESSION Setup a new crypto session for a new type of operation.
CIOCFSESSION Free a previously established session.
CIOCCRYPT Perform a crypto operation against a previously setup
session.
FEATURES
Depending on hardware being present, the following symmetric and
asymmetric cryptographic features are potentially available from
/dev/crypto:
CRYPTO_DES_CBC
CRYPTO_3DES_CBC
CRYPTO_BLF_CBC
CRYPTO_CAMELLIA_CBC
CRYPTO_CAST_CBC
CRYPTO_SKIPJACK_CBC
CRYPTO_MD5_HMAC
CRYPTO_SHA1_HMAC
CRYPTO_RIPEMD160_HMAC
CRYPTO_MD5_KPDK
CRYPTO_SHA1_KPDK
CRYPTO_AES_CBC
CRYPTO_AES_XTS
CRYPTO_AES_CTR
CRYPTO_AES_GCM_16
CRYPTO_AES_GMAC
CRYPTO_AES_128_GMAC
CRYPTO_AES_192_GMAC
CRYPTO_AES_256_GMAC
CRYPTO_TWOFISH_CBC
CRYPTO_SERPENT_CBC
CRYPTO_TWOFISH_XTS
CRYPTO_SERPENT_XTS
CRYPTO_ARC4
CRYPTO_MD5
CRYPTO_SHA1
CRK_MOD_EXP
CRK_MOD_EXP_CRT
CRK_DSA_SIGN
CRK_DSA_VERIFY
CRK_DH_COMPUTE_KEY
FILES
/dev/crypto crypto access device
SEE ALSO
aesni(4), crypto(9)
HISTORY
The crypto driver first appeared in OpenBSD 3.0. The crypto driver was
imported to FreeBSD 5.0.
DragonFly 6.5-DEVELOPMENT April 21, 2018 DragonFly 6.5-DEVELOPMENT