DragonFly On-Line Manual Pages
CORETEMP(4) DragonFly Kernel Interfaces Manual CORETEMP(4)
coretemp -- device driver for Intel Core on-die digital thermal sensor
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The coretemp driver provides support for the on-die digital thermal sen-
sors, both core level and package level, for Intel Core and newer CPUs.
The values are exposed through the HW_SENSORS sysctl(3) tree. For exam-
hw.sensors.cpu0.temp0: 50.00 degC (node0 core0), OK
hw.sensors.cpu1.temp0: 50.00 degC (node0 core0), OK
hw.sensors.cpu2.temp0: 47.00 degC (node0 core1), OK
hw.sensors.cpu3.temp0: 47.00 degC (node0 core1), OK
hw.sensors.cpu_node0.temp0: 50.00 degC (node0), OK
systat(1), sysctl(3), sensorsd(8), sysctl(8)
The coretemp driver first appeared in FreeBSD 7.0.
The coretemp driver was written by Rui Paulo <rpaulo@FreeBSD.org> as part
of a Google Summer of Code project. This manual page was written by
Dag-Erling Smorgrav <des@FreeBSD.org>.
DragonFly 4.1 April 12, 2015 DragonFly 4.1