DragonFly On-Line Manual Pages
CONFIG(8) DragonFly System Manager's Manual CONFIG(8)
NAME
config - build system configuration files
SYNOPSIS
config [-gr] [-d destdir] SYSTEM_NAME
DESCRIPTION
The config utility builds a set of system configuration files from the
file SYSTEM_NAME which describes the system to configure. A second file
tells config what files are needed to generate a system and can be
augmented by configuration specific set of files that give alternate
files for a specific machine (see the FILES section below).
Available options and operands:
-d destdir Use destdir as the output directory, instead of the
default one. Note that config does not append
SYSTEM_NAME to the directory given.
-g Configure a system for debugging.
-r Remove the old compile directory (see below).
SYSTEM_NAME Specify the name of the system configuration file
containing device specifications, configuration options
and other system parameters for one system
configuration.
config should be run from the config subdirectory of the system source
(usually /sys/config). config creates the directory
../compile/SYSTEM_NAME or the one given with the -d option as necessary
and places all output files there. If the output directory already
exists and the -r flag was specified, it will be removed first. The
output of config consists of a number of files; for the x86_64
architecture, they are: ioconf.c, a description of what I/O devices are
attached to the system; Makefile, used by make(1) in building the system;
header files, definitions of the number of various devices that will be
compiled into the system.
After running config, it is necessary to run "make depend" in the
directory where the new makefile was created.
If any other error messages are produced by config, the problems in the
configuration file should be corrected and config should be run again.
Attempts to compile a system that had configuration errors are likely to
fail.
If the options INCLUDE_CONFIG_FILE is used in the configuration file the
entire input file is embedded in the new kernel. This means that
strings(1) can be used to extract it from a kernel: to extract the
configuration information, use the command
strings -n 3 kernel | sed -n 's/^___//p'
DEBUG KERNELS
Traditional BSD kernels are compiled without symbols due to the heavy
load on the system when compiling a "debug" kernel. A debug kernel
contains complete symbols for all the source files, and enables an
experienced kernel programmer to analyse the cause of a problem. The
debuggers available prior to 4.4BSD-Lite were able to find some
information from a normal kernel; kgdb(1) provides very little support
for normal kernels, and a debug kernel is needed for any meaningful
analysis.
In order to ease posting bug reports for inexperienced users and make the
debugging environment more uniform, DragonFly installs kernel and modules
unstripped. Debug information is not loaded into memory, so the only
impact is a growth in root file-system consumption by 60MB. Those
wishing to install stripped down kernel and modules can specify two new
makeoptions in their kernel config file or when they run the kernel-
related targets to make:
INSTALLSTRIPPED=1 The installed kernel and modules will be
stripped of debug info.
INSTALLSTRIPPEDMODULES=1 The installed modules will be stripped of
debug info. The kernel will be left with
debug info intact.
Backup copies of the kernel and modules are automatically stripped of
their debug information by objcopy(1), unless NO_KERNEL_OLD_STRIP is set
in make.conf(5).
FILES
/sys/conf/files list of common files system is
built from
/sys/config/SYSTEM_NAME default location for kernel
configuration file
/sys/config/LINT64 kernel configuration file for
checking all the sources, includes
description of kernel configuration
options
/sys/config/VKERNEL64 default 64 bit vkernel(7) kernel
configuration file
/sys/config/X86_64_GENERIC default x86_64 kernel configuration
file
/sys/compile/SYSTEM_NAME default kernel build directory for
system SYSTEM_NAME
/sys/platform/PLATFORM/conf/Makefile generic makefile for the PLATFORM
/sys/platform/PLATFORM/conf/files list of PLATFORM specific files
SEE ALSO
gprof(1), kgdb(1), make(1), kernconf(5), build(7), vkernel(7)
The SYNOPSIS portion of each device in section 4.
Building 4.3 BSD UNIX System with Config.
HISTORY
The config utility appeared in 4.1BSD.
BUGS
The line numbers reported in error messages are usually off by one.
DragonFly 6.5-DEVELOPMENT January 5, 2019 DragonFly 6.5-DEVELOPMENT