DragonFly On-Line Manual Pages
COMCONTROL(8) DragonFly System Manager's Manual COMCONTROL(8)
comcontrol -- control a special tty device
comcontrol special_device [dtrwait number] [drainwait number]
The comcontrol utility is used to examine and modify some of the special
characteristics of the specified tty device. If no arguments other than
the device (or "-" for stdin) are specified, it prints the settings of
all controllable characteristics. This usage requires only read access
on the device. Only the superuser can change the settings.
The following options are available:
Set the time to wait after dropping DTR to the given number. The
units are hundredths of a second. The default is 300 hundredths,
i.e., 3 seconds. This option needed mainly to set proper recover
time after modem reset.
Set the time to wait for output drain to the given number. The
units are seconds. The default is 0 minutes, 0 means waiting
forever. This option needed mainly to specify upper limit of
minutes to prevent modem hanging.
The standard way to use comcontrol is to put invocations of it in the
/etc/rc.d/serial startup script.
/dev/ttyd? dialin devices, hardwired terminals
/dev/cuaa? dialout devices
Originally part of cgd's com package patches, version 0.2.1, to 386BSD
0.1. Once controlled bidirectional capabilities. Little is left to con-
trol now that these capabilities are standard.
Christopher G. Demetriou
DragonFly 3.5 May 15, 1994 DragonFly 3.5