DragonFly On-Line Manual Pages
CD(9) DragonFly Kernel Developer's Manual CD(9)
cd -- CDROM driver for the CAM SCSI subsystem
The cd device driver provides a read only interface for CDROM drives
(SCSI type 5) and WORM drives (SCSI type 4) that support CDROM type com-
mands. Some drives don't behave as the driver expects. See the section
QUIRKS for info on possible flags.
Each CD-ROM device can have different interpretations of the SCSI spec.
This can lead to drives requiring special handling in the driver. The
following is a list of quirks that the driver recognize.
CD_Q_NO_TOUCH This flag tell the driver not to probe the drive at
attach time to see if there is a disk in the drive and
find out what size it is. This flag is currently unim-
plemented in the CAM cd driver.
CD_Q_BCD_TRACKS This flag is for broken drives that return the track
numbers in packed BCD instead of straight decimal. If
the drive seems to skip tracks (tracks 10-15 are
skipped) then you have a drive that is in need of this
CD_Q_NO_CHANGER This flag tells the driver that the device in question
is not a changer. This is only necessary for a CDROM
device with multiple luns that are not a part of a
CD_Q_CHANGER This flag tells the driver that the given device is a
multi-lun changer. In general, the driver will figure
this out automatically when it sees a LUN greater than
0. Setting this flag only has the effect of telling the
driver to run the initial read capacity command for LUN
0 of the changer through the changer scheduling code.
/sys/bus/cam/scsi/scsi_cd.c is the driver source file.
The cd manual page first appeared in FreeBSD 2.2.
This manual page was written by John-Mark Gurney <email@example.com>. It
was updated for CAM and FreeBSD 3.0 by Kenneth Merry <ken@FreeBSD.org>.
DragonFly 3.5 October 10, 1998 DragonFly 3.5