DragonFly On-Line Manual Pages
BWN(4) DragonFly Kernel Interfaces Manual BWN(4)
bwn -- Broadcom BCM43xx IEEE 802.11b/g wireless network driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The bwn driver provides support for Broadcom BCM43xx based PCI/CardBus
It supports station and monitor mode operation. Only one virtual inter-
face may be configured at any time. For more information on configuring
this device, see ifconfig(8).
This driver requires firmware to be loaded before it will work. The
dports/net/bwn-firmware-kmod port needs to be installed before
ifconfig(8) will work. In most cases you need to use the bwn_v4_ucode
module but if you are a LP (low power) PHY user please use the
The bwn driver supports Broadcom BCM43xx based wireless devices, includ-
Card Chip Bus Standard
Apple Airport Extreme BCM4318 PCI b/g
ASUS WL-138g BCM4318 PCI b/g
Buffalo WLI-CB-G54S BCM4318 CardBus b/g
Dell Wireless 1390 BCM4311 Mini PCI b/g
Dell Wireless 1470 BCM4318 Mini PCI b/g
Dell Truemobile 1400 BCM4309 Mini PCI b/g
HP Compaq 6715b BCM4312 PCI b/g
HP nx6125 BCM4319 PCI b/g
Linksys WPC54G Ver 3 BCM4318 CardBus b/g
Linksys WPC54GS Ver 2 BCM4318 CardBus b/g
US Robotics 5411 BCM4318 CardBus b/g
Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev bwn0 inet 192.168.0.20 \
Join a specific BSS network with network name ``my_net'':
ifconfig wlan create wlandev bwn0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev bwn0 ssid my_net \
wepmode on wepkey 0x1234567890 weptxkey 1 up
Tunables can be set at the loader(8) prompt before booting the kernel or
stored in loader.conf(5).
By default, the driver will use MSI if it is supported. This
behavior can be turned off by setting this tunable to 0.
This tunable enables DMA operations on the hardware. If the
value is 0, PIO mode would be used. The default value is 1.
arp(4), cardbus(4), ifmedia(4), intro(4), pci(4), wlan(4), wlan_amrr(4),
The bwn driver first appeared in FreeBSD 8.1.
The bwn driver was written by Weongyo Jeong <weongyo@FreeBSD.org>.
Some LP PHY devices have DMA operation problems. In that case try to use
the PIO mode.
DragonFly 4.3 April 5, 2014 DragonFly 4.3