DragonFly On-Line Manual Pages
BTCONFIG(8) DragonFly System Manager's Manual BTCONFIG(8)
btconfig -- configure bluetooth devices
btconfig [-svz] [device [parameters]]
btconfig is used to configure Bluetooth devices. If the device is given,
but no parameters, then btconfig will print information about the device.
If no device is given, a basic list of devices will be printed.
When the -l flag is used, just the device names will be printed.
The following parameters may be specified with btconfig:
up Enable Bluetooth Device.
down Disable Bluetooth Device.
pscan Enable Page Scan. This enables incoming connections to the
-pscan Disable Page Scan.
iscan Enable Inquiry Scan. This puts the device in Discoverable
-iscan Disable Inquiry Scan.
encrypt Enable encryption. This will cause the device to request
encryption on all baseband connections, and will only work
if authentication is also enabled.
-encrypt Disable encryption.
auth Enable authentication. This will cause the device to
request authentication for all baseband connections.
-auth Disable authentication.
switch Enable Role Switching.
-switch Disable Role Switching.
hold Enable Hold Mode.
-hold Disable Hold Mode.
sniff Enable Sniff Mode.
-sniff Disable Sniff Mode.
park Enable Park Mode.
-park Disable Park Mode.
name name Set human readable name of device.
ptype type Set packet types. type is a 16 bit hex value specifying
packet types that will be requested by outgoing ACL connec-
tions. By default, all packet types that the device sup-
ports are enabled, see bluetooth specifications for more
information if you want to change this.
class class Set class of device. class is a 3 byte hex value the value
of which declares the device capabilities. See Bluetooth
Assigned Numbers documents at https://www.bluetooth.org/ for
details of constructing a "Class of Device" value. As a
starter, 0x020104 means Desktop Computer, with Networking
fixed Set fixed pin type.
variable Set variable pin type.
inquiry Perform device Discovery from the specified device and print
rssi Enable Remote Signal Strength Indicator (RSSI) in inquiry
results. This will only work if the device features indi-
cate <RSSI with inquiry result>.
-rssi Disable Remote Signal Strength Indicator (RSSI) in inquiry
reset Perform a hard reset on the device and re-initialise system
voice Set Voice Setting. [This should be 0x0060 for now]
pto Set Page Timeout value. This is a decimal value in mil-
scomtu Change SCO mtu value. This is a decimal value, see ubt(4)
for reasons why you may need to do this.
All parameters are parsed before any device operations take place. Each
time the -v flag is given, verbosity levels will be increased.
Super-user privileges are required to change device configurations.
Messages indicating the specified device does not exist, the requested
address is unknown, or the user is not privileged and tried to alter an
The btconfig command was written for NetBSD 4.0 by Iain Hibbert under the
sponsorship of Itronix, Inc and was imported into DragonFly 1.11.
The output is very messy.
DragonFly 4.1 September 7, 2007 DragonFly 4.1