DragonFly On-Line Manual Pages
BATTD(8) DragonFly System Manager's Manual BATTD(8)
battd -- Battery status monitoring daemon
battd [-dEhT] [-c seconds] [-e command] [-f device] [-p percent]
[-s status] [-t minutes]
The battd daemon monitors the status of the battery or batteries present
in the system. The daemon will alert all users on the system and may
execute a supplied command once a particular criterion has been met. The
criteria are based on the percentage remaining, the time remaining and
the status of the battery.
The options are as follows:
Interval in seconds for checking the battery status. Default is
-d Start in debug mode (works when battd is compiled with -DDEBUG).
Execute command once condition has been met.
-E Execute command only once after a condition has been met.
Specifies a different device path to be used. Default is
-h Print battd command line usage and exit.
Alert users when the remaining battery life has reached approxi-
mately percent. Default is 10. A value of 0 turns this alert
Alert users when the remaining battery has reached a given sta-
tus. The status specified can either be high, low or critical.
Alert users when the remaining battery time has reached approxi-
-T Alert users when the system has approximately 10 minutes remain-
ing battery time, but don't execute command (-e) on this alert.
battd -p 50 -s low
Alert users when the battery percentage has reached 50% and once again
when the status reaches low.
battd -t 15 -c 10
Alert users when the battery has 15 minutes worth of power remaining and
once again when battery percentage has reached 10%. Decrease the inter-
val between checking the battery to 10 seconds.
battd -Tt4 -p0 -Ee "/sbin/shutdown -p +2 Battery_Low"
Alert users when the battery has 10 minutes worth power remaining and
alert again when 4 minutes is remaining and then execute the given
shutdown(8) command once. (User will have to kill(1) the shutdown(8)
process, if AC power is connected to system and shutdown isn't wanted.)
viapm(4), apm(8), apmd(8), syslogd(8), zzz(8)
The battd command first appeared in DragonFly 1.1.
Liam J. Foy <firstname.lastname@example.org>
Man page contributions by:
Maxime Labelle <email@example.com>
Sarunas Vancevicius <firstname.lastname@example.org>
DragonFly 3.9 April 6, 2009 DragonFly 3.9