DragonFly On-Line Manual Pages
ARP(8) DragonFly System Manager's Manual ARP(8)
arp -- address resolution display and control
arp [-n] [-c cpu] hostname
arp [-n] [-c cpu] -a
arp -d hostname [pub]
arp -d -a
arp -s hostname ether_addr [temp] [pub [only]]
arp -S hostname ether_addr [temp] [pub [only]]
arp -f filename
The arp utility displays and modifies the Internet-to-Ethernet address
translation tables used by the address resolution protocol (arp(4)).
With no flags, the program displays the current ARP entry for hostname.
The host may be specified by name or by number, using Internet dot nota-
-a The program displays or deletes all of the current ARP entries.
-c cpu On SMP systems the route table is replicated. This option allows
the route table for a specific cpu to be accessed and exists pri-
marily for debugging purposes.
-d A super-user may delete an entry for the host called hostname
with the -d flag. If the pub keyword is specified, only the
``published'' ARP entry for this host will be deleted.
Alternatively, the -d flag may be combined with the -a flag to
delete all entries.
-n Show network addresses as numbers (normally arp attempts to dis-
play addresses symbolically).
-s hostname ether_addr
Create an ARP entry for the host called hostname with the Ether-
net address ether_addr. The Ethernet address is given as six hex
bytes separated by colons. The entry will be permanent unless
the word temp is given in the command. If the word pub is given,
the entry will be ``published''; i.e., this system will act as an
ARP server, responding to requests for hostname even though the
host address is not its own. In this case the ether_addr can be
given as auto in which case the interfaces on this host will be
examined, and if one of them is found to occupy the same subnet,
its Ethernet address will be used. If the only keyword is also
specified, this will create a ``published (proxy only)'' entry.
This type of entry is created automatically if arp detects that a
routing table entry for hostname already exists.
-S hostname ether_addr
Is just like -s except any existing ARP entry for this host will
be deleted first.
Cause the file filename to be read and multiple entries to be set
in the ARP tables. Entries in the file should be of the form
hostname ether_addr [temp] [pub]
with argument meanings as given above. Leading whitespace and
empty lines are ignored. A `#' character will mark the rest of
the line as a comment.
inet(3), arp(4), ifconfig(8)
The arp utility appeared in 4.3BSD.
DragonFly 3.9 June 6, 1993 DragonFly 3.9