DragonFly On-Line Manual Pages
AN(4) DragonFly Kernel Interfaces Manual AN(4)
an -- Aironet Communications 4500/4800 wireless network adapter driver
The an driver provides support for Aironet Communications 4500 and 4800
wireless network adapters. This includes the PCI and PCMCIA varieties.
The 4500 series adapters operate at 1 and 2Mbps while the 4800 series can
operate at 1, 2, 5.5 and 11Mbps. The PCI and PCMCIA devices are all
based on the same core PCMCIA modules and all have the same programming
interface, however unlike the Lucent WaveLAN/IEEE cards, the PCI cards
appear to the host as normal PCI devices and do not require any PCCARD
support. The PCMCIA Aironet cards require kernel pccard driver support.
PCI cards require no switch settings of any kind and will be automati-
cally probed and attached.
All host/device interaction with the Aironet cards is via programmed I/O.
The Aironet devices support 802.11 and 802.3 frames, power management,
BSS (infrastructure) and IBSS (ad-hoc) operation modes. The an driver
encapsulates all IP and ARP traffic as 802.11 frames, however it can
receive either 802.11 or 802.3 frames. Transmit speed is selectable
between 1Mbps, 2Mbps, 5.5Mbps, 11Mbps or "auto" (the NIC automatically
chooses the best speed).
By default, the an driver configures the Aironet card for infrastructure
For more information on configuring this device, see ifconfig(8)
an%d: init failed The Aironet card failed to come ready after an ini-
tialization command was issued.
an%d: failed to allocate %d bytes on NIC The driver was unable to allo-
cate memory for transmit frames in the NIC's on-board RAM.
an%d: device timeout The Aironet card failed to generate an interrupt to
acknowledge a transmit command.
arp(4), ifmedia(4), netintro(4), ancontrol(8), ifconfig(8)
The an device driver first appeared in FreeBSD 4.0.
The an driver was written by Bill Paul <firstname.lastname@example.org>.
DragonFly 3.7 September 10, 1999 DragonFly 3.7