DragonFly On-Line Manual Pages
ALTQ(4) DragonFly Kernel Interfaces Manual ALTQ(4)
ALTQ -- alternate queuing of network packets
The ALTQ framework provides several disciplines for queuing outgoing net-
work packets. This is done by modifications to the interface packet
queues. See altq(9) for details.
The user interface for ALTQ is implemented by the pfctl(8) utility, so
please refer to the pfctl(8) and the pf.conf(5) manpages for a complete
description of the ALTQ capabilities and how to use it.
The following options in the kernel configuration file are related to
ALTQ Enable ALTQ.
ALTQ_CBQ Build the ``Class Based Queuing'' discipline.
ALTQ_RED Build the ``Random Early Detection'' extension.
ALTQ_RIO Build ``Random Early Drop'' for input and output.
ALTQ_HFSC Build the ``Hierarchical Packet Scheduler'' discipline.
ALTQ_PRIQ Build the ``Priority Queuing'' discipline.
ALTQ_FAIRQ Build the ``Fair Queuing'' discipline.
ALTQ_NOPCC Required if the TSC is unusable.
ALTQ_DEBUG Enable additional debugging facilities.
Note that ALTQ-disciplines cannot be loaded as kernel modules. In order
to use a certain discipline you have to build it into a custom kernel.
The pf(4) interface, that is required for the configuration process of
ALTQ can be loaded as a module.
pf(4), pf.conf(5), ipfw(8), pfctl(8), altq(9)
DragonFly 4.3 April 6, 2008 DragonFly 4.3