DragonFly On-Line Manual Pages
ACPIEXEC(8) DragonFly System Manager's Manual ACPIEXEC(8)
acpiexec -- load ACPI tables and execute control methods from user space
acpiexec [option ...] aml_file ...
The following options are supported:
Batch mode command line execution (cmd1;cmd2;...).
-da Disable method abort on error.
-di Disable execution of STA/INI methods during init.
-do Disable Operation Region address simulation.
-dr Disable repair of method return values.
-ds Disable method auto-serialization.
-dt Disable allocation tracking (performance).
-ef Enable display of final memory statistics.
-ei Enable additional tests for ACPICA interfaces.
-el Enable loading of additional test tables.
-es Enable Interpreter Slack Mode.
-et Enable debug semaphore timeout.
Specify namespace initialization file.
Operation Region initialization fill value.
-h Display the help message.
-? Alias for -h.
Batch mode method execution. The default method is MAIN.
-r Use hardware-reduced FADT V5.
-v Display version information.
-vi Verbose initialization output.
-vr Verbose region handler output.
Debug output level.
From within the interactive mode, use `?' or ``help'' to see a list of
available AML Debugger commands.
acpi(4), acpibin(8), acpiconf(8), acpidump(8), acpihelp(8), acpinames(8),
The acpiexec utility is provided by Intel as part of their ACPICA distri-
This manual page was written by Sascha Wildner.
DragonFly 4.3 November 8, 2014 DragonFly 4.3