DragonFly On-Line Manual Pages

Search: Section:  


VFS_UNMOUNT(9)        DragonFly Kernel Developer's Manual       VFS_UNMOUNT(9)

NAME

VFS_UNMOUNT -- unmount a filesystem

SYNOPSIS

#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_UNMOUNT(struct mount *mp, int mntflags, struct proc *p);

DESCRIPTION

Unmount a filesystem. Its arguments are: mp The filesystem. mntflags Various flags. p Process which is unmounting the filesystem. If the MNT_FORCE flag is specified then open files should be forcibly closed.

SEE ALSO

vflush(9), VFS(9), vnode(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 3.5 July 24, 1996 DragonFly 3.5

Search: Section: