DragonFly On-Line Manual Pages

Search: Section:  


MODULE_DEPEND(9)      DragonFly Kernel Developer's Manual     MODULE_DEPEND(9)

NAME

MODULE_DEPEND -- set kernel module dependencies

SYNOPSIS

#include <sys/module.h> MODULE_DEPEND(name, moddepend, int minversion, int prefversion, int maxversion);

DESCRIPTION

The MODULE_DEPEND() macro sets a dependency of the module called name on another kernel module moddepend, which has registered its version with MODULE_VERSION(). Three versions must be specified on which the module can depend: The minimal and maximal versions this module can depend on as well as the preferred version.

EXAMPLES

MODULE_DEPEND(foo, bar, 1, 3, 4);

SEE ALSO

DECLARE_MODULE(9), module(9), MODULE_VERSION(9)

AUTHORS

This manual page was written by Alexander Langer <alex@FreeBSD.org>. DragonFly 3.5 July 19, 2006 DragonFly 3.5

Search: Section: