DragonFly On-Line Manual Pages

Search: Section:  


EVENTHANDLER(9)       DragonFly Kernel Developer's Manual      EVENTHANDLER(9)

NAME

EVENTHANDLER_DECLARE, EVENTHANDLER_INVOKE, EVENTHANDLER_REGISTER, EVENTHANDLER_DEREGISTER, eventhandler_register, eventhandler_deregister, eventhandler_find_list -- kernel event handling functions

SYNOPSIS

#include <sys/eventhandler.h> EVENTHANDLER_DECLARE(name, type); EVENTHANDLER_INVOKE(name, ...); eventhandler_tag EVENTHANDLER_REGISTER(name, func, arg, priority); EVENTHANDLER_DEREGISTER(name, tag); eventhandler_tag eventhandler_register(struct eventhandler_list *list, const char *name, void *func, void *arg, int priority); void eventhandler_deregister(struct eventhandler_list *list, eventhandler_tag tag); struct eventhandler_list * eventhandler_find_list(const char *name);

DESCRIPTION

The EVENTHANDLER_DECLARE mechanism provides a way for kernel subsystems to register interest in kernel events and have their callback functions invoked when these events occur. The normal way to use this subsystem is via the macro interface. The macros that can be used for working with event handlers and callback function lists are: EVENTHANDLER_DECLARE() This macro declares an event handler named by argument name with callback functions of type type. EVENTHANDLER_REGISTER() This macro registers a callback function func with event handler name. When invoked, function func will be invoked with argument arg as its first parameter along with any additional parameters passed in via macro EVENTHANDLER_INVOKE() (see below). Callback functions are invoked in order of priority. The relative priority of each callback among other callbacks associated with an event is given by argument priority, which is an integer ranging from EVENTHANDLER_PRI_FIRST (highest priority), to EVENTHANDLER_PRI_LAST (lowest priority). The symbol EVENTHANDLER_PRI_ANY may be used if the handler does not have a specific priority associated with it. If registration is successful, EVENTHANDLER_REGISTER() returns a cookie of type eventhandler_tag. EVENTHANDLER_DEREGISTER() This macro removes a previously registered callback associated with tag tag from the event handler named by argument name. EVENTHANDLER_INVOKE() This macro is used to invoke all the callbacks associated with event handler name. This macro is a variadic one. Additional arguments to the macro after the name parameter are passed as the second and subsequent arguments to each registered callback function. The macros are implemented using the following functions: eventhandler_register() The eventhandler_register() function is used to register a callback with a given event. The arguments expected by this function are: list A pointer to an existing event handler list, or NULL. If list is NULL, the event handler list corresponding to argument name is used. name The name of the event handler list. func A pointer to a callback function. Argument arg is passed to the callback function func as its first argument when it is invoked. priority The relative priority of this callback among all the callbacks registered for this event. Valid values are those in the range EVENTHANDLER_PRI_FIRST to EVENTHANDLER_PRI_LAST. The eventhandler_register() function returns a tag that can later be used with eventhandler_deregister() to remove the particular callback function. eventhandler_deregister() The eventhandler_deregister() function removes the callback associated with tag tag from the event handler list pointed to by list. This function is safe to call from inside an event handler callback. eventhandler_find_list() The eventhandler_find_list() function returns a pointer to event handler list structure corresponding to event name. Kernel Event Handlers The following event handlers are present in the kernel: acpi_sleep_event Callbacks invoked when the system is being sent to sleep. acpi_wakeup_event Callbacks invoked when the system is being woken up. bpf_track Callbacks invoked when a BPF listener attaches to/detaches from network interface. group_attach_event Callbacks invoked when a new interface group has been created. group_change_event Callbacks invoked when the members of an interface group have changed. group_detach_event Callbacks invoked when an interface group has been removed due to no members. if_clone_event Callbacks invoked when a new interface cloner is attached. ifaddr_event Callbacks invoked when an address is set up on a network interface. iflladdr_event Callbacks invoked when an if link layer address event has happened. ifnet_attach_event Callbacks invoked when a new network interface appears. ifnet_detach_event Callbacks invoked when a network interface is removed. ifnet_event Callbacks invoked when a network interface is brought up or down. ifnet_link_event Callbacks invoked when the link state of an interface has changed. mountroot Callbacks invoked when root has been mounted. power_profile_change Callbacks invoked when the power profile of the system changes. shutdown_pre_sync Callbacks invoked at shutdown time, before file systems are synchronized. shutdown_post_sync Callbacks invoked at shutdown time, after all file systems are synchronized. shutdown_final Callbacks invoked just before halting the system. usb_dev_configured Callbacks invoked when a USB device is configured.

RETURN VALUES

The macro EVENTHANDLER_REGISTER() and function eventhandler_register() return a cookie of type eventhandler_tag, which may be used in a subsequent call to EVENTHANDLER_DEREGISTER() or eventhandler_deregister(). The eventhandler_find_list() function returns a pointer to an event handler list corresponding to parameter name, or NULL if no such list was found.

HISTORY

The EVENTHANDLER_DECLARE facility first appeared in FreeBSD 4.0.

AUTHORS

This manual page was written by Joseph Koshy <jkoshy@FreeBSD.org>. DragonFly 5.3 June 25, 2018 DragonFly 5.3

Search: Section: