DragonFly On-Line Manual Pages
EST(4) DragonFly Kernel Interfaces Manual EST(4)
est -- Enhanced SpeedStep Technology support
To compile this driver into the kernel, place the following line in your
kernel configuration file:
To load this driver as a module at boot time, place the following line in
The est driver provides support for the Enhanced SpeedStep Technology
present in newer CPUs.
If the CPU is supported est creates the following variables in the
machdep.est branch of the sysctl(3) MIB.
frequency.available The list of frequencies supported by est for
the CPU (read only).
frequency.current The current CPU frequency (read only).
frequency.target The target CPU frequency (read/write).
An associated userland daemon which is part of the pkgsrc(7) collection
(sysutils/estd) can be used to dynamically set the CPU frequency depend-
ing on utilization.
The est driver first appeared in DragonFly 1.5.
DragonFly 3.5 March 17, 2011 DragonFly 3.5