DragonFly On-Line Manual Pages
DUMMYNET(4) DragonFly Kernel Interfaces Manual DUMMYNET(4)
dummynet -- traffic shaper, bandwidth manager and delay emulator
dummynet is a system facility that permits the control of traffic going
through the various network interfaces, by applying bandwidth and queue
size limitations, implementing different scheduling and queue management
policies, and emulating delays and losses.
The user interface for dummynet is implemented by the ipfw program, so
the reader is referred to the ipfw(8) manpage for a complete description
of the capabilities of dummynet and on how to use it.
The following options in the kernel configuration file are related to
IPFIREWALL - enable ipfirewall (required for dummynet).
IPFIREWALL_VERBOSE - enable firewall output.
IPFIREWALL_VERBOSE_LIMIT - limit firewall output.
DUMMYNET - enable dummynet operation.
NMBCLUSTERS - set the amount of network packet buffers
Generally, the following options are required:
additionally, one may want to increase the number of mbuf clusters (used
to store network packets) according to the sum of the bandwidth-delay
products and queue sizes of all configured pipes. Timer granularity is
controlled by sysctl(8) variable net.inet.ip.dummynet.hz, which is set to
1000 by default.
setsockopt(2), bridge(4), ip(4), ipfw(8), sysctl(8)
dummynet was initially implemented as a testing tool for TCP congestion
control by Luigi Rizzo <firstname.lastname@example.org>, as described on ACM Computer
Communication Review, Jan.97 issue. Later it has been then modified to
work at the ip and bridging level, integrated with the IPFW packet fil-
ter, and extended to support multiple queueing and scheduling policies.
DragonFly 4.1 October 28, 2002 DragonFly 4.1