DragonFly On-Line Manual Pages
BUS_DMA(9) DragonFly Kernel Developer's Manual BUS_DMA(9)
NAME
bus_dma, bus_dma_tag_create, bus_dma_tag_destroy, bus_dmamap_create,
bus_dmamap_destroy, bus_dmamap_load, bus_dmamap_load_ccb,
bus_dmamap_load_mbuf, bus_dmamap_load_mbuf_segment,
bus_dmamap_load_mbuf_defrag, bus_dmamap_load_uio, bus_dmamap_unload,
bus_dmamap_sync, bus_dmamem_alloc, bus_dmamem_coherent,
bus_dmamem_coherent_any, bus_dmamem_free - Bus and Machine Independent
DMA Mapping Interface
SYNOPSIS
#include <sys/bus.h>
int
bus_dma_tag_create(bus_dma_tag_t parent, bus_size_t alignment,
bus_size_t boundary, bus_addr_t lowaddr, bus_addr_t highaddr,
bus_size_t maxsize, int nsegments, bus_size_t maxsegsz, int flags,
bus_dma_tag_t *dmat);
int
bus_dma_tag_destroy(bus_dma_tag_t dmat);
int
bus_dmamap_create(bus_dma_tag_t dmat, int flags, bus_dmamap_t *mapp);
int
bus_dmamap_destroy(bus_dma_tag_t dmat, bus_dmamap_t map);
int
bus_dmamap_load(bus_dma_tag_t dmat, bus_dmamap_t map, void *buf,
bus_size_t buflen, bus_dmamap_callback_t *callback,
void *callback_arg, int flags);
int
bus_dmamap_load_ccb(bus_dma_tag_t dmat, bus_dmamap_t map, union ccb *ccb,
bus_dmamap_callback_t *callback, void *callback_arg, int flags);
int
bus_dmamap_load_mbuf(bus_dma_tag_t dmat, bus_dmamap_t map,
struct mbuf *mbuf, bus_dmamap_callback2_t *callback,
void *callback_arg, int flags);
int
bus_dmamap_load_mbuf_segment(bus_dma_tag_t dmat, bus_dmamap_t map,
struct mbuf *mbuf, bus_dma_segment_t *segs, int maxsegs, int *nsegs,
int flags);
int
bus_dmamap_load_mbuf_defrag(bus_dma_tag_t dmat, bus_dmamap_t map,
struct mbuf **mbuf, bus_dma_segment_t *segs, int maxsegs, int *nsegs,
int flags);
int
bus_dmamap_load_uio(bus_dma_tag_t dmat, bus_dmamap_t map,
struct uio *uio, bus_dmamap_callback2_t *callback,
void *callback_arg, int flags);
int
bus_dmamem_alloc(bus_dma_tag_t dmat, void **vaddr, int flags,
bus_dmamap_t *mapp);
int
bus_dmamem_coherent(bus_dma_tag_t parent, bus_size_t alignment,
bus_size_t boundary, bus_addr_t lowaddr, bus_addr_t highaddr,
bus_size_t maxsize, int flags, bus_dmamem_t *dmem);
void *
bus_dmamem_coherent_any(bus_dma_tag_t parent, bus_size_t alignment,
bus_size_t maxsize, int flags, bus_dma_tag_t *dtag,
bus_dmamap_t *dmap, bus_addr_t *busaddr);
void
bus_dmamap_unload(bus_dma_tag_t dmat, bus_dmamap_t map);
void
bus_dmamap_sync(bus_dma_tag_t dmat, bus_dmamap_t map,
bus_dmasync_op_t op);
void
bus_dmamem_free(bus_dma_tag_t dmat, void *vaddr, bus_dmamap_t map);
DESCRIPTION
Direct Memory Access (DMA) is a method of transferring data without
involving the CPU, thus providing higher performance. A DMA transaction
can be achieved between device to memory, device to device, or memory to
memory.
The bus_dma API is a bus, device, and machine-independent (MI) interface
to DMA mechanisms. It provides the client with flexibility and
simplicity by abstracting machine dependent issues like setting up DMA
mappings, handling cache issues, bus specific features and limitations.
STRUCTURES AND TYPES
bus_dma_tag_t
A machine-dependent (MD) opaque type that describes the
characteristics of DMA transactions. DMA tags are organized
into a hierarchy, with each child tag inheriting the
restrictions of its parent. This allows all devices along the
path of DMA transactions to contribute to the constraints of
those transactions.
bus_dma_segment_t
A machine-dependent type that describes individual DMA segments.
bus_addr_t ds_addr;
bus_size_t ds_len;
The ds_addr field contains the device visible address of the DMA
segment, and ds_len contains the length of the DMA segment.
Although the DMA segments returned by a mapping call will adhere
to all restrictions necessary for a successful DMA operation,
some conversion (e.g. a conversion from host byte order to the
device's byte order) is almost always required when presenting
segment information to the device.
bus_dmamap_t
A machine-dependent opaque type describing an individual
mapping. Multiple DMA maps can be associated with one DMA tag.
bus_dmamem_t
A machine-dependent type that describes DMA memory created by
bus_dmamem_coherent().
bus_dma_tag_t dmem_tag;
bus_dmamap_t dmem_map;
void *dmem_addr;
bus_addr_t dmem_busaddr;
The dmem_tag field contains the DMA tag of the DMA memory and
dmem_map field contains the DMA map of the DMA memory. The
dmem_addr field points to the allocated DMA memory in kernel
virtual address space. The dmem_busaddr field contains the
device visible address of the DMA memory.
bus_dmamap_callback_t
Client specified callback for receiving mapping information
resulting from the load of a bus_dmamap_t via bus_dmamap_load()
or bus_dmamap_load_ccb(). Callbacks are of the format:
void client_callback(void *callback_arg, bus_dma_segment_t
*segs, int nseg, int error)
The callback_arg is the callback argument passed to dmamap load
functions. The segs and nseg parameters describe an array of
bus_dma_segment_t structures that represent the mapping. This
array is only valid within the scope of the callback function.
The success or failure of the mapping is indicated by the error
parameter. More information on the use of callbacks can be
found in the description of the individual dmamap load
functions.
bus_dmamap_callback2_t
Client specified callback for receiving mapping information
resulting from the load of a bus_dmamap_t via
bus_dmamap_load_uio() or bus_dmamap_load_mbuf().
Callback2s are of the format:
void client_callback2(void *callback_arg, bus_dma_segment_t
*segs, int nseg, bus_size_t mapsize, int error)
Callback2's behavior is the same as bus_dmamap_callback_t with
the addition that the length of the data mapped is provided via
mapsize.
bus_dmasync_op_t
Memory synchronization operation specifier. Bus DMA requires
explicit synchronization of memory with its device visible
mapping in order to guarantee memory coherency. The
bus_dmasync_op_t allows the type of DMA operation that will be
or has been performed to be communicated to the system so that
the correct coherency measures are taken. All operations
specified below are performed from the DMA engine's point of
view:
BUS_DMASYNC_PREREAD Perform any synchronization required
after an update of memory by the CPU but
prior to DMA read operations.
BUS_DMASYNC_PREWRITE Perform any synchronization required
after an update of memory by the CPU but
prior to DMA write operations.
BUS_DMASYNC_POSTREAD Perform any synchronization required
after DMA read operations, but prior to
CPU access of the memory.
BUS_DMASYNC_POSTWRITE Perform any synchronization required
after DMA write operations, but prior to
CPU access of the memory.
FUNCTIONS
bus_dma_tag_create(parent, alignment, boundary, lowaddr, highaddr,
maxsize, nsegments, maxsegsz, flags, *dmat)
Allocates a device specific DMA tag, and initializes it
according to the arguments provided:
parent Indicates restrictions between the parent bridge, CPU
memory, and the device. May be NULL, if no DMA
restrictions are to be inherited.
alignment Alignment constraint, in bytes, of any mappings
created using this tag. The alignment must be a
power of 2. Hardware that can DMA starting at any
address would specify 1 for byte alignment. Hardware
requiring DMA transfers to start on a multiple of 4K
would specify 4096.
boundary Boundary constraint, in bytes, of the target DMA
memory region. The boundary indicates the set of
addresses, all multiples of the boundary argument,
that cannot be crossed by a single bus_dma_segment_t.
The boundary must be either a power of 2 or 0. `0'
indicates that there are no boundary restrictions.
lowaddr
highaddr Bounds of the window of bus address space that cannot
be directly accessed by the device. The window
contains all address greater than lowaddr and less
than or equal to highaddr. For example, a device
incapable of DMA above 4GB, would specify a highaddr
of BUS_SPACE_MAXADDR and a lowaddr of
BUS_SPACE_MAXADDR_32BIT. Similarly a device that can
only dma to addresses below 16MB would specify a
highaddr of BUS_SPACE_MAXADDR and a lowaddr of
BUS_SPACE_MAXADDR_24BIT. Some implementations
requires that some region of device visible address
space, overlapping available host memory, be outside
the window. This area of `safe memory' is used to
bounce requests that would otherwise conflict with
the exclusion window.
maxsize Maximum size, in bytes, of the sum of all segment
lengths in a given DMA mapping associated with this
tag.
nsegments Number of discontinuities (scatter/gather segments)
allowed in a DMA mapped region. If there is no
restriction, BUS_SPACE_UNRESTRICTED may be specified
for the tag intended to be used as the parent.
BUS_SPACE_UNRESTRICTED must not be specified for the
tags which will be used to create maps. For tags
which will be used to create maps, this argument must
be less than 16384 on x86_64.
maxsegsz Maximum size, in bytes, of a segment in any DMA
mapped region associated with dmat.
flags Are as follows:
BUS_DMA_ALLOCNOW Allocate the minimum resources
necessary to guarantee that
all map load operations
associated with this tag may
not block. If sufficient
resources are not available,
ENOMEM is returned.
BUS_DMA_WAITOK Indicates that it is OK to
wait for resources. However,
unlike kmalloc(9), it is not
guaranteed that the resource
allocation will succeed. This
flag is the default one, if
BUS_DMA_NOWAIT is not
supplied.
BUS_DMA_NOWAIT If the resource allocation
request cannot be immediately
fulfilled, ENOMEM is returned.
BUS_DMA_ONEBPAGE Allocte one bounce page at
most, even if the maxsize
indicates that multiple bounce
pages are needed.
BUS_DMA_ALIGNED Indicates that all memory to
be loaded into the DMA maps
associated with this DMA tag
is properly aligned according
to alignment constraint. No
resources, e.g. bounce pages,
will be allocated due to the
alignment constraint. If
unaligned memory was loaded
into the DMA maps associated
with this DMA tag, system will
panic.
BUS_DMA_PRIVBZONE Uses a private bounce zone
instead of a shared one. A
private bounce zone will
vanish if the DMA tag is
destroyed.
BUS_DMA_ALLOCALL Allocate all required
resources (mainly the bounce
buffer). If any allocation
fails, bus_dma_tag_create()
fails.
BUS_DMA_PROTECTED All of the functions called
with the DMA tag are already
protected by the caller, so
the bus_dma code need not
protect the internal data
structures.
dmat Pointer to a bus_dma_tag_t where the resulting DMA
tag will be stored.
Returns ENOMEM if sufficient memory is not available for tag
creation or allocating mapping resources.
bus_dma_tag_destroy(dmat)
Deallocate the DMA tag dmat that was created by
bus_dma_tag_create().
Returns EBUSY if any DMA maps remain associated with dmat or `0'
on success.
bus_dmamap_create(dmat, flags, *mapp)
Allocates and initializes a DMA map. Arguments are as follows:
dmat DMA tag.
flags Are as follows:
BUS_DMA_WAITOK Indicates that it is OK to wait
for resources. However, unlike
kmalloc(9), it is not
guaranteed that the resource
allocation will succeed. This
flag is the default one, if
BUS_DMA_NOWAIT is not supplied.
BUS_DMA_NOWAIT If the resource allocation
request cannot be immediately
fulfilled, ENOMEM is returned.
BUS_DMA_ONEBPAGE Allocte one bounce page at
most, even if the maxsize used
to create the dmat indicates
that multiple bounce pages are
needed.
mapp Pointer to a bus_dmamap_t where the resulting DMA map
will be stored.
Returns ENOMEM if sufficient memory is not available for
creating the map or allocating mapping resources.
bus_dmamap_destroy(dmat, map)
Frees all resources associated with a given DMA map. Arguments
are as follows:
dmat DMA tag used to allocate map.
map The DMA map to destroy.
Returns EBUSY if a mapping is still active for map.
bus_dmamap_load(dmat, map, buf, buflen, *callback, ...)
Creates a mapping in device visible address space of buflen
bytes of buf, associated with the DMA map map. Arguments are as
follows:
dmat DMA tag used to allocate map.
map A DMA map without a currently active mapping.
buf A kernel virtual address pointer to a contiguous (in
KVA) buffer, to be mapped into device visible address
space.
buflen The size of the buffer.
callback callback_arg
The callback function, and its argument.
flags The value of this argument is currently undefined, and
should be specified as `0'.
Return values to the caller are as follows:
0 The callback has been called and completed.
The status of the mapping has been delivered to
the callback.
EINPROGRESS The mapping has been deferred for lack of
resources. The callback will be called as soon
as resources are available. Callbacks are
serviced in FIFO order. DMA maps created from
DMA tags that are allocated with the
BUS_DMA_ALLOCNOW flag will never return this
status for a load operation.
EINVAL The load request was invalid. The callback has
not, and will not be called. This error value
may indicate that dmat, map, buf, or callback
were invalid, or buslen was larger than the
maxsize argument used to create the dma tag
dmat.
When the callback is called, it is presented with an error value
indicating the disposition of the mapping. Error may be one of
the following:
0 The mapping was successful and the dm_segs
callback argument contains an array of
bus_dma_segment_t elements describing the
mapping. This array is only valid during the
scope of the callback function.
EFBIG A mapping could not be achieved within the
segment constraints provided in the tag even
though the requested allocation size was less
than maxsize.
bus_dmamap_load_ccb(dmat, map, ccb, callback, callback_arg, flags)
This is a variation of bus_dmamap_load() which maps data pointed
to by ccb for DMA transfers.
bus_dmamap_load_mbuf(dmat, map, mbuf, callback2, callback_arg, flags)
This is a variation of bus_dmamap_load() which maps mbuf chains
for DMA transfers. A bus_size_t argument is also passed to the
callback routine, which contains the mbuf chain's packet header
length.
Mbuf chains are assumed to be in kernel virtual address space.
Returns EINVAL if the size of the mbuf chain exceeds the maximum
limit of the DMA tag.
bus_dmamap_load_mbuf_segment(dmat, map, mbuf, *segs, maxsegs, *nsegs,
flags)
It is like bus_dmamap_load_mbuf() without callback.
Segmentation information are saved in the segs and nsegs if the
loading is successful. The maxsegs, which indicates the number
of elements in the segs, must be set by the caller and must be
at least 1 and at most equal the nsegments used to create the
dmat. The flags must have BUS_DMA_NOWAIT turned on.
This function will not block. When system is short of DMA
resources, this function will return ENOMEM, instead of
EINPROGRESS.
bus_dmamap_load_mbuf_defrag(dmat, map, *mbuf, *segs, maxsegs, *nsegs,
flags)
This function is like bus_dmamap_load_mbuf_segment(), but it
will call m_defrag() on the *mbuf and try reloading, if low
level code indicates too many fragments in the *mbuf; the mbuf
will be updated under this situation. However, *mbuf would not
be freed by this function, even if m_defrag() failed.
Return ENOBUFS, if the calling of m_defrag() failed.
bus_dmamap_load_uio(dmat, map, uio, callback2, callback_arg, flags)
This is a variation of bus_dmamap_load() which maps buffers
pointed to by uio for DMA transfers. A bus_size_t argument is
also passed to the callback routine, which contains the size of
uio, i.e. uio->uio_resid.
If uio->uio_segflg is UIO_USERSPACE, then it is assumed that the
buffer, uio is in uio->uio_td->td_proc's address space. User
space memory must be in-core and wired prior to attempting a map
load operation.
bus_dmamap_unload(dmat, map)
Unloads a DMA map. Arguments are as follows:
dmat DMA tag used to allocate map.
map The DMA map that is to be unloaded.
bus_dmamap_unload() will not perform any implicit
synchronization of DMA buffers. This must be done explicitly by
a call to bus_dmamap_sync() prior to unloading the map.
bus_dmamap_sync(dmat, map, op)
Performs synchronization of a device visible mapping with the
CPU visible memory referenced by that mapping. Arguments are as
follows:
dmat DMA tag used to allocate map.
map The DMA mapping to be synchronized.
op Type of synchronization operation to perform. See the
definition of bus_dmasync_op_t for a description of the
acceptable values for op.
bus_dmamap_sync() is the method used to ensure that CPU and
device DMA access to shared memory is coherent. For example,
the CPU might be used to setup the contents of a buffer that is
to be DMA'ed into a device. To ensure that the data are visible
via the device's mapping of that memory, the buffer must be
loaded and a dma sync operation of BUS_DMASYNC_PREREAD must be
performed. Additional sync operations must be performed after
every CPU write to this memory if additional DMA reads are to be
performed. Conversely, for the DMA write case, the buffer must
be loaded, and a dma sync operation of BUS_DMASYNC_PREWRITE must
be performed. The CPU will only be able to see the results of
this DMA write once the DMA has completed and a
BUS_DMASYNC_POSTWRITE operation has been performed.
If DMA read and write operations are not preceded and followed
by the appropriate synchronization operations, behavior is
undefined.
bus_dmamem_alloc(dmat, **vaddr, flags, mapp)
Allocates memory that is mapped into KVA at the address returned
in vaddr that is permanently loaded into the newly created
bus_dmamap_t returned via mapp. Arguments are as follows:
dmat DMA tag describing the constraints of the DMA
mapping.
vaddr Pointer to a pointer that will hold the returned KVA
mapping of the allocated region.
flags Flags are defined as follows:
BUS_DMA_WAITOK The routine can safely wait
(sleep) for resources.
BUS_DMA_NOWAIT The routine is not allowed to
wait for resources. If
resources are not available,
ENOMEM is returned.
BUS_DMA_COHERENT Attempt to map this memory such
that cache sync operations are
as cheap as possible. This
flag is typically set on memory
that will be accessed by both a
CPU and a DMA engine,
frequently. Use of this flag
does not remove the requirement
of using bus_dmamap_sync, but
it may reduce the cost of
performing these operations.
BUS_DMA_ZERO Causes the allocated memory to
be set to all zeros.
BUS_DMA_NOCACHE The allocated memory will not
be cached in the processor
caches. All memory accesses
appear on the bus and are
executed without reordering.
On x86_64, the BUS_DMA_NOCACHE
flag results in the Strong
Uncacheable PAT to be set for
the allocated virtual address
range.
mapp Pointer to storage for the returned DMA map.
The size of memory to be allocated is maxsize as specified in
dmat.
The current implementation of bus_dmamem_alloc() will allocate
all requests as a single segment.
Although no explicit loading is required to access the memory
referenced by the returned map, the synchronization requirements
as described in the bus_dmamap_sync() section still apply.
Returns ENOMEM if sufficient memory is not available for
completing the operation.
bus_dmamem_coherent(parent, alignment, boundary, lowaddr, highaddr,
maxsize, flags, *dmem)
This is a convenient function to create one segment of DMA
memory. It combines following bus_dma function calls:
bus_dma_tag_create(..., dtag);
bus_dmamem_alloc(*dtag, vaddr, ..., dmap);
bus_dmamap_load(*dtag, *dmap, *vaddr, ..., \
callback, busaddr, ...);
The final results of the above function calls are: DMA tag, DMA
map, DMA memory's kernel virtual address and its device visible
address. bus_dmamem_coherent() saves the results in *dmem.
The parent, alignment, boundary, lowaddr and highaddr will be
passed to bus_dma_tag_create() as they are. The maxsize will be
passed to bus_dma_tag_create() as its maxsize and maxsegsz and
`1' will be passed to bus_dma_tag_create() as its nsegments.
When bus_dmamem_alloc() is called, flags will be first or'ed
with BUS_DMA_COHERENT then passed to it. The final results of
the above three functions, i.e. DMA tag, DMA map, DMA memory's
kernel virtual address and its device visible address, are saved
in *dmem. If any of the three functions failed, this function
will return the error code and the *dmem should not be used.
bus_dmamem_coherent_any(parent, alignment, maxsize, flags, *dtag, *dmap,
*busaddr)
This function is a simplified version of bus_dmamem_coherent()
with its boundary set to `0', lowaddr set to BUS_SPACE_MAXADDR
and highaddr set to BUS_SPACE_MAXADDR. The parent usually
should not be NULL.
Return the DMA memory's kernel virtual address. The DMA tag,
DMA map and device visible address are returned in *dtag, *dmap,
and *busaddr. If this function failed, NULL will be returned;
*dtag, *dmap, and *busaddr are left unchanged.
bus_dmamem_free(dmat, *vaddr, map)
Frees memory previously allocated by bus_dmamem_alloc(). Any
mappings will be invalidated. Arguments are as follows:
dmat DMA tag.
vaddr Kernel virtual address of the memory.
map DMA map to be invalidated.
RETURN VALUES
Behavior is undefined if invalid arguments are passed to any of the above
functions. If sufficient resources cannot be allocated for a given
transaction, ENOMEM is returned. All routines that are not of type,
void, will return 0 on success or an error code, as discussed above.
All void routines will succeed if provided with valid arguments.
SEE ALSO
devclass(9), device(9), driver(9), rman(9)
Jason R. Thorpe, "A Machine-Independent DMA Framework for NetBSD",
Proceedings of the Summer 1998 USENIX Technical Conference, USENIX
Association, June 1998.
HISTORY
The bus_dma interface first appeared in NetBSD 1.3.
The bus_dma API was adopted from NetBSD for use in the CAM SCSI
subsystem. The alterations to the original API were aimed to remove the
need for a bus_dma_segment_t array stored in each bus_dmamap_t while
allowing callers to queue up on scarce resources.
AUTHORS
The bus_dma interface was designed and implemented by Jason R. Thorpe of
the Numerical Aerospace Simulation Facility, NASA Ames Research Center.
Additional input on the bus_dma design was provided by Chris Demetriou,
Charles Hannum, Ross Harvey, Matthew Jacob, Jonathan Stone, and Matt
Thomas.
This manual page was written by Hiten Pandya and Justin T. Gibbs.
DragonFly 6.5-DEVELOPMENT December 9, 2023 DragonFly 6.5-DEVELOPMENT