DragonFly On-Line Manual Pages
BGE(4) DragonFly Kernel Interfaces Manual BGE(4)
bge -- Broadcom BCM570x PCI gigabit ethernet adapter driver
The bge driver provides support for various NICs based on the Broadcom
BCM570x family of gigabit ethernet controller chips, including the fol-
* 3Com 3c996-T (10/100/1000baseT)
* Dell PowerEdge 2550 integrated BCM5700 NIC (10/100/1000baseT)
* Netgear GA302T (10/100/1000baseT)
* SysKonnect SK-9D21 (10/100/1000baseT)
* SysKonnect SK-9D41 (1000baseSX)
All of these NICs are capable of 10, 100 and 1000Mbps speeds over CAT5
copper cable, except for the SysKonnect SK-9D41 which supports only
1000Mbps over multimode fiber. The BCM570x builds upon the technology of
the Alteon Tigon II. It has two R4000 CPU cores and is PCI v2.2 and PCI-
X v1.0 compliant. It supports IP, TCP and UDP checksum offload for both
receive and transmit, multiple RX and TX DMA rings for QoS applications,
rules-based receive filtering, and VLAN tag stripping/insertion as well
as a 256-bit multicast hash filter. Additional features may be provided
via value-add firmware updates. The BCM570x supports TBI (ten bit inter-
face) and GMII transceivers, which means it can be used with either cop-
per or 1000baseX fiber applications. Note however the device only sup-
ports a single speed in TBI mode.
Most cards also use the Broadcom BCM5401 or BCM5411 10/100/1000 copper
gigabit transceivers, which support autonegotiation of 10, 100 and
1000mbps modes in full or half duplex.
The BCM5700 also supports jumbo frames, which can be configured via the
interface MTU setting. Selecting an MTU larger than 1500 bytes with the
ifconfig(8) utility configures the adapter to receive and transmit jumbo
frames. Using jumbo frames can greatly improve performance for certain
tasks, such as file transfers and data streaming.
The bge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can
also be used to select either full-duplex or half-duplex
100baseTX Set 100Mbps (fast ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either
full-duplex or half-duplex modes.
1000baseT Set 1000baseT operation over twisted pair. full-duplex and
half-duplex modes are supported.
1000baseSX Set 1000Mbps (gigabit ethernet) operation. Both full-duplex
and half-duplex modes are supported.
The bge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
The bge driver also supports one special link option for 1000baseT cards:
link0 With 1000baseT cards, establishing a link between two ports
requires that one port be configured as a master and the other a
slave. With autonegotiation, the master/slave settings will be
chosen automatically. However when manually selecting the link
state, it is necessary to force one side of the link to be a mas-
ter and the other a slave. The bge driver configures the ports as
slaves by default. Setting the link0 flag with ifconfig(8) will
set a port as a master instead.
For more information on configuring this device, see ifconfig(8). The
bge driver supports polling(4).
hw.bge.fake_autoneg Set to 1 for some IBM blade servers, if auto-negoti-
ation between the onboard bge and the switch module
is broken. Disabled by default.
bge%d: couldn't map memory A fatal initialization error has occurred.
bge%d: couldn't map ports A fatal initialization error has occurred.
bge%d: couldn't map interrupt A fatal initialization error has occurred.
bge%d: no memory for softc struct! The driver failed to allocate memory
for per-device instance information during initialization.
bge%d: failed to enable memory mapping! The driver failed to initialize
PCI shared memory mapping. This might happen if the card is not in a
bge%d: no memory for jumbo buffers! The driver failed to allocate memory
for jumbo frames during initialization.
bge%d: watchdog timeout The device has stopped responding to the net-
work, or there is a problem with the network connection (cable).
arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), polling(4),
The bge device driver first appeared in FreeBSD 4.5.
The bge driver was written by Bill Paul <firstname.lastname@example.org>.
DragonFly 3.9 March 4, 2007 DragonFly 3.9